Thursday, May 14, 2015

Introducing... Raven!

Arena is out, Raven is in!  As far as I can tell this game is basically Firepower with the useless multiball nonsense removed.  ;)
Yes yes yes, this game has a reputation.   Fuck the haters, I think I'm going to like this one.

On initial inspection:  there is no ground prong on the plug.  oopsies!
Left flipper has some movement issues.
A number of the standup targets need serious adjustment in relation to the playfield and surrounding plastics.  This might also mean flattening some distorted plastics.
The ramp and chopper are there intact, so that's always a good sign.  I can't imagine any NOS for those kicking around...
Playfield itself has some raising around the inserts, which I can't really do much about.  But it still has the mylar, so all in all decent condition.  Minimal broken plastics, too.

Tilt bob missing, rolling tilt ball also missing.
Subwoofer detached...
I also didn't know which pole to attach the speaker cable, but sharp-eyed pinsiders helped me with that.  Thank goodness for technology.  Sometimes I should photograph stuff right in front of me just so I can do a better digital zoom and check out details in ideal lighting.

Turned it on, and yes I know it's a touch of a risk considering the ground is gone...
30% of the lights are out.  Display seems great.  Plays well, and even the chopper works.  Held my breathe until I saw it's blade spin when the spinner is active.
Pops are out, and that's most likely a fuse issue.  I should get on top of inspecting the fuses, first and foremost.  I can't imagine this game, in the shape it is now, is properly fused.  Prove me wrong, Raven.  Prove Me Wrong.

(No really, sit down and eat yr damn fuses.)

I dove in to the fuses and immediately found this:
Notice anything?

yeah... nope.  Let's get a better F4 in there.

Lots of incorrect fuses found:
F11 was 5, should be 1
F10 was 3, should be 1
F9 was 8, should be 1
F6 was 10, should be 7.5
F12 through F15, bumper fuses, were each 3-4, but should be 2.   I only had 3A fuses, so I will have to order a bunch of the 2A ones.
F15 was blown.
F16 was 5, should be 2.5

SOUND:  gimme, please?

With the speaker attached (see above,) I turned it on and only heard background music.  Nothing else.  No sounds at all when you hit targets.  That can't be right, can it?  *quickly checks youtube play videos* yeah no that's not right.

But first I wanted to plug in the subwoofer.  I quickly noticed that the positive wire was plugged to the negative node.  Ummmm not sure if this sub will actually be any good then, but let's try.  I swapped that wire, and hooked up the ground to the minus sign node.

Then, to the manual to check on sound.

yes, this is an actual line from the manual. 

but then there is this part:
So on the sound board is a 4-bank dip switch.  Only one option for toggling though.  Both position 3 and 4 were in the same position, so I adjusted them and lo and behold the sound effects were on.
This begs the question: WHY HAVE THE TOGGLES FOR 3 AND 4 IF THEY AREN'T TO BE SWITCHED?  bah, whatever.  The sound are working now and they are awesome.


Bottom right sniper doesn't raise
Upper right sniper often doesn't lower
All of the effects lighting (strip up to ramp on the left, center circle of red lights) doesn't work at all.
Pop bumpers are all out
Slingshots need major adjustment
did I mention so many lights are out?

Time to get to it!

No comments:

Post a Comment